[pygtk] OS X Deployment

Bertrand Kintanar b3rxkintanar at gmail.com
Tue Jul 21 20:29:39 WST 2009


On 7/21/09 3:19 PM, Chris Van Bael wrote:
> Hi,
>
> unfortunately I cannot help you, but maybe you can help me ;-)
>
> I'm still struggling with installing PyGTK on OSX.
> Did you use the system's Python (from Apple) or Python's Python (from
> Python.org)?
> I tried the route of jhbuild, but PyGTK only gets installed in the
> system's Python.
> Do you know how it can be installed with Python's Python using jhbuild?
>
> Thanks,
>
> Chris
>    
Sure! no probs. Well first of, were you able to install the GTK+ OSX 
framework? you need that to be able to make PyGTK to work. ill send you 
a log of my jhbuild installation.

im not sure what the best setup instructions but here's what worked for me..

   1. download gtk-osx-build-setup.sh from:
      http://github.com/jralls/gtk-osx-build/raw/master/gtk-osx-build-setup.sh
      and save it to your home directory.
   2. fire up terminal and navigate to your home directory and run the
      command sh gtk-osx-build-setup.sh
   3. the shell script will warn you that ~/.local/bin isnt added to
      your envorinment variable to do this, edit your .profile file
      located at your home directory and /User/<username>/.local/bin to
      your environment variable. to know more on how to edit this file
      check out:
      http://www.tech-recipes.com/rx/2621/os_x_change_path_environment_variable/
   4. after that, do a ~/.local/bin/jhbuild bootstrap command. it will
      download and install some necessary utilities.
   5. download and install the beta version of the gtk+ osx framework
      at:
      http://ftp.imendio.com/pub/imendio/gtk-osx/Gtk-Framework-2.14-LATEST.dmg
   6. before installing the meta-gtk-osx-python, you need to build and
      install some other packages that jhbuild doesnt install
      automatically, so what i did was i installed libpng by doing the
      command: ~/.local/bin/jhbuild build libpng
   7. you also need to install libtiff so do the command:
      ~/.local/bin/jhbuild build libtiff
   8. and also gtk-doc is needed so: ~/.local/bin/jhbuild build gtk-doc
   9. and finally you can now install meta-gtk-osx-python by doing a:
      ~/.local/bin/jhbuild build meta-gtk-osx-python

*** I hope that helps. this was done by the default username and by not 
doing a sudo command. ***

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://www.daa.com.au/pipermail/pygtk/attachments/20090721/b07ce6e4/attachment.htm 


More information about the pygtk mailing list