[pygtk] libglade, python and gnome widgets: segmentation fault

Christian Reis kiko@async.com.br
Wed, 30 Oct 2002 12:03:18 -0300


On Wed, Oct 23, 2002 at 01:33:25PM +0100, Padraig Brady wrote:
>  >
>  > GnomeUI-CRITICAL **: file gnome-app.c: line 208 (gnome_app_new): assertion 
> `appname != NULL' failed.
>  >
>  > Gtk-WARNING **: invalid cast from (NULL) pointer to `GnomeApp'
>  > zsh: segmentation fault
>  >
> 
> OK I would like to release a python app using libglade that
> just has a dependency on gtk and not gnome. The above is still
> happening on my RH7.3 system so is there a work around or
> is it possible at all to not import gnome.ui ?

You don't have to import gnome.ui. Your glade file appears to define a
GnomeApp in it, however, which mandates it. Change the glade file to use
only GTK+ widgets and you should be fine.

Take care,
--
Christian Reis, Senior Engineer, Async Open Source, Brazil.
http://async.com.br/~kiko/ | [+55 16] 261 2331 | NMFL